
What is Draw?
Draw is a graphical applet that is called on by the main Ability applications - Write, Spreadsheet and 
Database - whenever they need to use vector drawing tools.

On its own, Draw can be used to create and save graphical designs like letterheads, logos, and 
emblems. These can be reused later by Write or Spreadsheet.

With Draw you can create lines, shapes and text boxes and insert pictures from other applications.

See:

Starting Draw 

Parts of the Draw window 

Creating a drawing 



Starting Draw

To start Draw, follow these steps:

1. Click the Start button on the Windows Taskbar

2. Select Programs

3. Select Ability Office 98

4. Select Ability Draw

Draw will open with a new document ready for adding graphics. 



Parts of the Draw window

The draw window consists of standard toolbars, for operations like opening files and cutting shapes, a 
set of rulers and the draw document itself. You can have many draw documents open at once. 

There are three toolbars that are specific to Draw:

Tools bar - used to add draw objects shapes to your document.

Color toolbar - set foreground and background colors for draw objects.

Align toolbar - aligns and centers selected draw objects.

These toolbars will also appear in other Ability applications that use Draw (for example, in Database 
when designing a form or in Write or Spreadsheet when a drawing is inserted).

To help work with the draw objects, the Draw window also has:

Rulers and gridlines

A Grid



The tools bar

The tools bar is a set of drawing tools which provide the main method of adding any element to your 
document.

For more details, see adding a shape.



The color toolbar

The color toolbar is a palette of colors.

You use the color bar to choose the colors you want to use when drawing with a tool or changing the color
settings of an existing draw object.
· Click on a color to set the back-color (the color of the insides of a shape).

· Right-click on a color to set the fore-color (the color of the lines in a shape).

· Click on the Custom color button to define your own mix of colors.

For more details, see setting the color of draw objects.



The align toolbar

The align toolbar allows you to align, size and center multiple draw objects.

For more details, see:
Spacing objects 
Aligning objects 
Resizing objects together 



The rulers and gridlines

Across the top and down the left of the document window are the rulers. 

As you move the mouse pointer across the screen, you will see the gridlines - markers on the rulers - 
moving as well. These indicate your exact position.

You can choose not to display the rulers - select the Ruler command    from the View menu. 

See also: the grid.



The grid

When snap control is turned on, any objects you create, resize or move will jump or ‘snap’ to align 
themselves with the grid divisions. This is usually the best way of working with Draw as it is easy to 
create and align objects manually.

To control the grid, select Grid Setup from the Tools menu and then:

· In the Horizontal box, type the number of horizontal grid points you want per unit of measurement.

· In the Vertical box, type the number of vertical grid lines you want per unit of measurement.

· Use the Always Snap To Grid. checkbox to turn snap on and off.

When grid snap is on, it may be useful to view the grid points. Select the Grid button  or select Grid
from the View menu. Note that Draw may only display every other grid point (or every third or fouth) if 
the number of grid points per unit of measurement is too high to display on screen without crowding. In 
this case, movement will still obey the underlying grid settings.

If you've drawn and positioned an object when grid snap is turned off, you can align it to the grid by 
selecting it, right-clicking and selecting Align to Grid (or use the Align to Grid form the Format menu).

See also: rulers and gridlines.



Creating a drawing
When you start Draw, you are automatically given a new document. 

Click on the New button  on the toolbar to create a new drawing. Alternatively, select the New 
command from the File menu.

Now use the tools bar to add lines, shapes and text (draw objects) to the drawing. See:
Adding a shape 

Drawing a text box 

Inserting a picture 

Once you've added some draw objects, you'll need to be able to move, size and format them. See:

Selecting, moving and resizing draw objects 

Formatting a shape 



Adding a shape

Shapes can all be added using the tools bar .

Lines

Drawing a line 

Drawing a polyline 

Solid shapes

Drawing a square or rectangle 

Drawing an ellipse or circle 

Drawing an arc 

Drawing a polygon. 



Drawing a line

To draw a line:

1. Select the    Line button .

2. Press the mouse button (without releasing it) to start the line, drag the mouse, and release the 
button to complete it.

See also:

Formatting a shape 

Selecting, moving and resizing draw objects 

For details on other shapes, see: adding a shape.



Drawing a polyline

A polyline is two or more lines connected together. You could make the letter "W" using the polyline 
tool.

To create a polyline:

1. Select the Polyline    button .

2. Click at the start of the line, move the mouse and click again when you wish to start a new segment
of the line. Continue moving the mouse and clicking to draw connected lines. 

3. Double-click with the mouse to finish the polyline.

You can also use the polyline tool to draw a freehand line by dragging the mouse without depressing 
the mouse button. 

Note: Unlike the Polygon Tool, double clicks on the end point does not close the shape unless you 
manually join the start and end points. You cannot fill a closed polyline with a color.

See also:

Formatting a shape 

Selecting, moving and resizing draw objects 

For details on other shapes, see: adding a shape.



Drawing a square or rectangle

To draw a square or rectangle:

1. Select the Rectangle button .

2. Press the mouse button to start the rectangle, drag the mouse, and release the button to complete 
it.

Use the Rounded Rectangle button instead to draw a square or rectangle with  rounded corners.

See also:

Formatting a shape 

Selecting, moving and resizing draw objects 

For details on other shapes, see: adding a shape.



Drawing an ellipse or circle

To draw an ellipse or circle:

1. Select the Ellipse button .

2. Press the mouse button to start the ellipse, drag the mouse, and release the button to complete it.

See also:

Formatting a shape 

Selecting, moving and resizing draw objects 

For details on other shapes, see: adding a shape.



Drawing a polygon

To draw a polygon (a many sided shape):

1. Select the Polygon button .

2. Click to start the polygon, move the pointer and click again to finish the first edge.

3. Repeat step 2 for as many edges as you want.

4. Double-click to complete the shape - Draw automatically joins the first and last points with a 
straight line.

You can also use the polygon tool to draw a freehand shape by dragging the mouse without depressing
the mouse button. 

See also:

Formatting a shape 

Selecting, moving and resizing draw objects 

For details on other shapes, see: adding a shape.



Drawing an arc

To draw an arc, that is a segment of a circle:

1. Select the Arc button .

2. Press the mouse button (without releasing it) to start the arc, drag the mouse, and release the 
button to complete it. The direction in which you drag determines which quadrant you draw. 

3. Use the handles midway along each edge of the arc to adjust the angle:

See also:

Formatting a shape 

Selecting, moving and resizing draw objects 

For details on other shapes, see: adding a shape.



Drawing a text box

To put text into a drawing, you need to add a text box. A text box can contain a word, a line or several 
paragraphs.

To add a text box:

1. Click on the Text box button  in the toolbar

2. Press the mouse button (without releasing it) to start the text box, drag the mouse to the end point, 
and release the button. Alternatively, just click on the page - a default sized text box will be added.

3. Type the text you require, and then press enter to finish.

The text will wrap to fit the width and depth of the text box you draw – you can fit more text into the box 
by increasing its size.

You can put several paragraphs in a single text box – type the first line or paragraph and then press 
ctrl+enter to start a new line. This works in the same way the enter key does in Write.

If you want the text to appear without any background or border, set these styles to None - see line and
fill styles.

See also:

Setting the text alignment 

Formatting a shape 

Selecting, moving and resizing draw objects 

For details on other shapes, see: adding a shape.



Inserting pictures

To insert a picture into a drawing:

1. Select Picture from the Insert menu. The “Open” dialog box is displayed. Select the picture file 
you wish to use, and click on the OK button. 

2. Position the picture by clicking on the page where you would like it to appear.

You can also use the clipboard to paste pictures into a drawing. For example, press ALT-Print Screen to

get a snapshot of any window and then select the Paste button  to insert it into Draw.

See also: Selecting, moving and resizing draw objects 



Selecting, moving and resizing draw objects
See:

Selecting a single object 

Selecting multiple objects 

Moving a draw object 

Resizing a draw object 



Selecting a single object

To select a single object, click on the Select button  and then click on the object. Black “handles” 
will appear to indicate that the object has been selected:

See also: selecting multiple objects 



Selecting multiple objects

Click on the Select button  and do one of the following:

· Click outside the objects in question, and drag a selection box around them all. When the box is 
surrounding the shapes you require, release the mouse button. All the objects within the selection 
will now display their handles.

· Click on the first object and then click on subsequent objects with the Shift key held down.

· Choose the Select All command from the Edit menu to select every object in the drawing.

When a group of objects has been selected, "handles" will appear on every selected object:

See also: selecting a single object 



Moving a draw object

To move a draw object or objects:

1. Select the objects (see selecting multiple objects).

2. Drag it to a new location.

See also: resizing a draw object 



Resizing a draw object

To resize a draw object:

1. Select the object (see selecting a single object).

2. Drag a handle to a new location:

To force a rectangle into a square or an ellipse into a circle, select the object, right-click and select the 
Set as Square or Set as Circle command.

For sizing multiple objects, see sizing objects.



Formatting a shape
All draw objects have common properties that you can be changed:

Line and fill styles 

Colors 

In addition, text boxes have three other properties:

Text alignment 

Text box border style 

Fonts in text boxes 



Line and fill styles

A draw object has a line pattern and width and, for solid objects, a fill pattern. By default these are solid 
line 1 point wide and solid color. You can change these styles for one or more objects and also the 
default setting:

1. Select the object or objects (see selecting multiple objects for more details).

2. Right-click and select Properties.

3. Select the Style tab

As an alternative to steps 2 and 3, select the Style command from the Format menu. 

Next, choose from the following:

· Select Brush Style to see the range of available fill patterns. This sets the pattern of the interior of 
the object. If you want a simple color (the default) select Solid. If you want the shape to be 
transparent, select None.

· Select Pen Style to see the range of available line styles. This sets the style for the outline of the 
shape. If you don’t want an outline to appear around a shape, select None.

To change the default settings for new objects, make sure no objects are selected (to do this, click in a 
blank area of the drawing), right-click and select Defaults from the shortcut menu. Follow the 
instructions for pen and brush style as above.

For details on other shape formatting see: formatting a shape.



Setting the color of draw objects

Shapes - rectangles, ellipses, polygons and text boxes - have two color properties: a fore-color and 
back-color. The fore-color is the color of the lines and back-color is the inside area of the shape. Lines 
only have a fore-color.

To set these colors:

1. Select the object or objects (see selecting multiple objects for more details).

2. Click on a color on the color toolbar to set the back-color.

3. Right-click on a color on the color toolbar to set the fore-color. 

As an alternative to steps 2 and 3, select the Color command from the Format menu.

To change the default settings for new objects, make sure no objects are selected (to do this, click in a 
blank area of the drawing) and use the color toolbar to set the colors you want.

Note setting the back-color as white is not the same as having a transparent object. To do this, set the 
fill style to None instead - see line and fill styles.

For details on other shape formatting see: formatting a shape.



Text box border style

Text boxes have an additional border property compared to other draw objects. To set the border 
property.

To set the border property:

1. Select the object or objects (see selecting multiple objects for more details).

2. Right-click and select Properties.

3. Select the Border tab.

As an alternative to steps 2 and 3, select the Border command from the Format menu. 

Next, choose from the following:

· None. Turns off the border altogether.

· Standard. Plain border according to the pen style (see line and fill styles).

· Sunken. Creates a 3D sunken effect. To see this effect properly you need to set the text box back-
color to be the same as the page background (and this should not be white).

· Raised. Creates a raised effect. To see this effect properly, apply the same conditions above for 
Sunken.

· Shadowed. Puts a dropped shadow around the text box.

· Double. Same as Standard but a double line box is drawn.

Note that you can create the effect of a rectangle having a border property by adding a text box without 
entering any text. 

See also: 

Fonts in text boxes 

Text alignment 



Fonts in text boxes

A text box can use any font and font style. Fonts cannot be mixed within a text box

To set the font of text within a text box:

1. Select the text box or boxes (see selecting multiple objects for more details).

2. Right-click and select Properties.

3. Select the Font tab.

As an alternative to steps 2 and 3, select the Font command from the Format menu. 

In the Font box, choose the font you require. Choose the style in the Font Style box, and the size in 
the Size box. A preview of your choices is shown in the Sample box.

See also: 

Text alignment 

Text box border style 



Text alignment

To set the alignment of text within a text box:

1. Select the text box or boxes (see selecting multiple objects for more details).

2. Right-click and select Properties.

3. Select the Align tab.

As an alternative to steps 2 and 3, select the Text Align command from the Format menu. 

Choose from:

· Left
· Center
· Right
See also: 

Fonts in text boxes 

Text box border style 



Working with groups of objects
See:

Resizing objects together 

Overlapping objects 

Aligning objects 

Spacing objects 

Grouping draw objects 



Resizing objects together

To evenly size two or more objects, first select them (see selecting multiple objects ) and then use any 
of the following buttons.

Make Same Width. All the selected objects are adjusted to have the same width.

 Make Same Height. . All the selected objects are adjusted to have the same height.

 Make Same Size. . All the selected objects are adjusted to have the same height and width.
All these commands are also available under Same Size in the Format menu.



Overlapping objects

Even the simplest drawing can contain overlapping objects, so you need control over the order in which
objects appear in the drawing.

· To bring an object (or selection of objects) to the front of a drawing, right-click and select the To 
Front command (also available from the Format menu).

· To send an object (or selection of objects) to the back of a drawing right-click and select the To 
Back command (also available from the Format menu). 



Aligning objects

To align two or more objects, first select them (see selecting multiple objects ) and then use any of the 
following buttons.

 Align Left. Aligns the left edges of all selected objects to the left edge of the left-most selected 
object.

 Align Right. Aligns the right edges of all selected objects to the right edge of the right-most 
selected object.

Align Top. Aligns the top edges of all selected objects to the top edge of the top-most selected 
object.

 Align Bottom. Aligns the bottom edges of all selected objects to the bottom edge of the bottom-
most selected object.

 Center Vertical. Aligns vertically the center points of all selected objects around the center point 
between the outer edges of the highest selected object and the lowest selected object.

 Center Horizontal. Aligns horizontally the center points of all selected objects with the center 
point between outer edges of the left-most selected object and the right-most selected object.
All these commands are also available under Align in the Format menu.



Spacing objects

To evenly space three or more objects, first select them (see selecting multiple objects ) and then use 
any of the following buttons.

 Space Down. Adjust the space between all the selected objects to be the same vertically.

 Space Across. Adjust the space between all the selected objects to be the same horizontally.
Both of these commands are also available under Space Evenly in the Format menu.



Grouping draw objects

Once you have positioned several draw objects in the positions you want relative to each other, you 
can group them together so Draw treats them all like a single object. In this way, you can prevent 
accidental movement of one of the elements.

To group objects together:

1. Select all the objects (see selecting multiple objects ) 

2. Right-click and select Group from the shortcut menu. The Group command is also availabel from 
the Tools menu.

When objects are grouped they can be moved and formatted as normal but they cannot be resized.

To split a group back into its individual objects, first select the group and then select the Ungroup 
command from either the shortcut or the Tools menus.



Draw object

Any drawing shape or line created from the tools bar - a line, rectangle, rounded rectangle, polyline, 
polygon, arc or text box.




